Prepare Your Computer

Prepare your computer before installing viam-server.

Make sure your system is compatible with Viam. Viam is supported on:

  • Linux 64-bit operating systems
  • macOS

If you are using a single board computer (SBC) like a Raspberry Pi or BeagleBone, prepare your SBC by following the relevant setup document:

If you plan to run viam-server on your laptop or desktop with a Linux or Mac operating system, no special prep is required. Proceed to install viam-server.